mirror of
https://gitlab.com/ahoneybun/nix-configs.git
synced 2025-05-12 03:04:03 -06:00
51 lines
1.6 KiB
Nix
51 lines
1.6 KiB
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
security.acme.acceptTerms = true;
|
|
security.acme.defaults.email = "aaronhoneycutt@proton.me";
|
|
|
|
services.nginx = {
|
|
enable = true;
|
|
recommendedTlsSettings = true;
|
|
recommendedOptimisation = true;
|
|
recommendedGzipSettings = true;
|
|
recommendedProxySettings = true;
|
|
|
|
virtualHosts = {
|
|
"hydra.ahoneybun.net" = {
|
|
forceSSL = true;
|
|
enableACME = true;
|
|
locations."/" = {
|
|
proxyPass = "http://127.0.0.1:3000";
|
|
|
|
extraConfig = ''
|
|
etag on;
|
|
gzip on;
|
|
|
|
add_header 'Access-Control-Allow-Origin' '*' always;
|
|
add_header 'Access-Control-Allow-Methods' 'POST, PUT, DELETE, GET, PATCH, OPTIONS' always;
|
|
add_header 'Access-Control-Allow-Headers' 'Authorization, Content-Type, Idempotency-Key' always;
|
|
add_header 'Access-Control-Expose-Headers' 'Link, X-RateLimit-Reset, X-RateLimit-Limit, X-RateLimit-Remaining, X-Request-Id' alway>
|
|
if ($request_method = OPTIONS) {
|
|
return 204;
|
|
}
|
|
add_header X-XSS-Protection "1; mode=block";
|
|
add_header X-Permitted-Cross-Domain-Policies none;
|
|
add_header X-Frame-Options DENY;
|
|
add_header X-Content-Type-Options nosniff;
|
|
add_header Referrer-Policy same-origin;
|
|
add_header X-Download-Options noopen;
|
|
proxy_http_version 1.1;
|
|
proxy_set_header Upgrade $http_upgrade;
|
|
proxy_set_header Connection "upgrade";
|
|
proxy_set_header Host $host;
|
|
|
|
client_max_body_size 16m;
|
|
# NOTE: increase if users need to upload very big files
|
|
'';
|
|
};
|
|
};
|
|
};
|
|
};
|
|
|
|
}
|