mirror of
https://gitlab.com/ahoneybun/nix-configs.git
synced 2025-05-12 03:04:03 -06:00
15 lines
No EOL
341 B
Nix
15 lines
No EOL
341 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
environment.etc."nextcloud-admin-pass".text = "test123";
|
|
services.nextcloud = {
|
|
enable = true;
|
|
https = true;
|
|
package = pkgs.nextcloud28;
|
|
hostName = "localhost";
|
|
config = {
|
|
adminpassFile = "/etc/nextcloud-admin-pass";
|
|
};
|
|
settings.trusted_domains = [ "10.0.0.10*" ];
|
|
};
|
|
} |