nix-configs/homelab/forgejo/default.nix
2025-02-25 13:42:32 +00:00

23 lines
No EOL
603 B
Nix

{ lib, pkgs, config, ... }:
let
cfg = config.services.forgejo;
srv = cfg.settings.server;
in
{
services.forgejo = {
enable = true;
database.type = "postgres";
# Enable support for Git Large File Storage
lfs.enable = true;
settings = {
server = {
DOMAIN = "git.ahoneybun.net";
# You need to specify this to remove the port from URLs in the web UI.
ROOT_URL = "https://${srv.DOMAIN}/";
HTTP_PORT = 3001;
};
# You can temporarily allow registration to create an admin user.
service.DISABLE_REGISTRATION = true;
};
};
}