mirror of
https://gitlab.com/ahoneybun/nix-configs.git
synced 2025-05-12 03:04:03 -06:00
34 lines
946 B
Nix
34 lines
946 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
environment.systemPackages = with pkgs; [
|
|
alacritty # gpu accelerated terminal
|
|
sway
|
|
wayland
|
|
xdg-utils # for openning default programms when clicking links
|
|
glib # gsettings
|
|
gnome3.adwaita-icon-theme # default gnome cursors
|
|
swaylock
|
|
swayidle
|
|
grim # screenshot functionality
|
|
slurp # screenshot functionality
|
|
wl-clipboard # wl-copy and wl-paste for copy/paste from stdin / stdout
|
|
bemenu # wayland clone of dmenu
|
|
mako # notification system developed by swaywm maintainer
|
|
wdisplays # A graphical application for configuring displays in Wayland compositors
|
|
];
|
|
|
|
services.dbus.enable = true;
|
|
xdg.portal = {
|
|
enable = true;
|
|
wlr.enable = true;
|
|
# gtk portal needed to make gtk apps happy
|
|
extraPortals = [ pkgs.xdg-desktop-portal-gtk ];
|
|
};
|
|
|
|
# enable sway window manager
|
|
programs.sway = {
|
|
enable = true;
|
|
wrapperFeatures.gtk = true;
|
|
};
|
|
}
|